192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

封端口和用NBAR在路由器上封BT的方法(附命令行)

发布时间:2012-01-18 13:49

不得不说虽然大陆运营商(不管是电信还是联通网通铁通有线通)宽带很普及而且带宽越来越大,但是很多热门影视剧和流行软件的BT下载还是会占据过多的带宽导致别人打开网页很卡很慢甚至只能上QQ(QQ也会偶尔掉线),遇到这类情况,大家都想在路由器上通过简单的办法把BT给封杀掉。

下面给出两种常见的路由器上封BT的方法,并附带命令行文件,便于您的操作。

第一是常用的封端口的方法:常用的命令如下:

1禁止∶
access-list 102 deny tcp any any range 6881 6890
access-list 102 deny tcp any range 6881 6890 any
access-list 102 permit ip any any

这种方法有其局限性,一是现在有的bt软件,再封锁后会自动改端口二是我仔细研究过好几个BT下载软件,它们现在的announce端口现在已经用8000、8080的说,如果连这个也封,那网络使用就有可能不正常(我这样做过,呵呵,后来N多人打电话找我,吓得我马上DEL掉了)

第二种方法:就是用NBAR (Network-Based Application Recognition)网络应用识别NBAR是一种动态能在四到七层寻找协议的技术,它不但能做到普通ACL能做到那样控制静态的TCP UDP的报,也能做到控制一般ACLs不能做到动态的端口的那些协议(如BT)之类.An external Packet Description Language Module (PDLM)的文件用来扩展NBAR识别的协议。过程:

1,到这个网址( http://www.cisco.com/pcgi-bin/tablebuild.pl/pdlm )下载bittorrent.pdlm,(要CCO的)。

2,放到TFTP,然后用copy tftp disk2(大多数应该是flash)
#show runn

得到关于BT的部分是:

class-map match-all bittorrent
match protocol bittorrent
!
!
policy-map bittorrent-policy
class bittorrent
drop
!
interface GigabitEthernet0/2
http://www.luyouqiwang.com/13411/
description CONNECT INSIDE
ip address 192.168.168.1 255.255.255.252 secondary
ip address 192.168.21.1 255.255.255.0
ip nat inside
service-policy input bittorrent-policy
service-policy output bittorrent-policy
duplex full
speed 1000
media-type rj45
no negotiation auto

经过证实,通过上述配置操作后,BT已经被封掉了。从此网络又恢复了顺畅。

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明