192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

使用Cisco Packer Trace之三层交换机+路由器共享上网

发布时间:2012-08-05 12:32
在一些特殊的网络中,需要三乘交换机和路由器来共同实现共享上网的功能,这时候就需要用到Cisco Packer Trace了,下文根据一个实例来讲解这种设置方法。
 
今天早上起来逛论坛的时候,看见一篇帖子。问如何解决以下的这个问题?
一台思科三层交换机划分3个vlan  
vlan 2:ip 192.168.1.1 255.255.255.0  192.168.1.254 网段
vlan 3 :ip  192.168.2.1 255.255.255.0  192.168.2.254
vlan 4 ip   192.168.3.1 255.255.255.0  192.168.3.254
各vlan 之间能互相通迅.
现在增加1台cisco路由想实现共享上网
cisco 路由器配置NAT,如何使用静态路由协议,实现各vlan上公网。
拓扑图如下:
image
我这里再说清楚一点嘛!我们的PC0、PC1处在VLAN2中,PC2、PC3处在VLAN3中,Server0处在VLAN4中。现在要使我们内网能够正常访问我们的Server0服务器,然后同时还要能够访问我们的ISP外网的WWW服务器。
那么我们现在从三层交换机开始来配置,我们现在来看看如何配置呢?
Switch#conf t


Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 2    创建VLAN2
Switch(config-vlan)#exi
Switch(config)#vlan 3    创建VLAN3
Switch(config-vlan)#exi
Switch(config)#vlan 4    创建VLAN4
Switch(config-vlan)#exit
Switch(config)#int fa0/1     将我们的fa0/1添加到VLAN2中
Switch(config-if)#sw mo ac
Switch(config-if)#sw ac vlan 2
Switch(config-if)#exit
Switch(config)#int fa0/2    将我们的FA0/2添加到VLAN3中
Switch(config-if)#sw mo ac
Switch(config-if)#sw ac vlan 3
Switch(config-if)#exit
Switch(config)#int fa0/3    将我们的FA0/3添加到VLAN4中
Switch(config-if)#sw mo ac
Switch(config-if)#sw ac vlan 4
Switch(config-if)#exit
Switch(config)#int vlan 2     给我们的VLAN2添加一个IP地址,用于不同网段之间互相访问
Switch(config-if)#ip add 192.168.1.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int vlan 3     给我们的VLAN3添加一个IP地址    
Switch(config-if)#ip add 192.168.2.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#int vlan 4    给我们的VLAN4添加一个IP地址


Switch(config-if)#ip add 192.168.3.1 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
以下几行是用给给我们不同的VLAN内的主机自动分配我们的IP地址。
Switch(config)#ip dhcp pool VLAN2
Switch(dhcp-config)#network 192.168.1.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.1.1
Switch(dhcp-config)#exit
Switch(config)#ip dhcp pool VLAN3
Switch(dhcp-config)#network 192.168.2.0 255.255.255.0
Switch(dhcp-config)#default-router 192.168.2.1
Switch(dhcp-config)#exit
Switch(config)#
我们现在去PC0上面看看能够分配到IP地址不?
image
image
image
image
image
我们服务器的IP地址一般都得手工配置,如果使用DHCP来自动分配的话,到最后那台服务器的IP地址是那一个我们都不太添楚呢?所以我们一般都是手工输入。
我们现在来测试一下看看我们内网,通过三层交换机在不同的VLAN间互相访问有没有问题?
image
image
从PC0上在我们可以看见,从PC0可以到达VLAN3与VLAN4,这就说明我们通过三层交换机,可以实现VLAN间路由,那么我们加一台路由器以后,我们怎么来解决呢?
Switch(config)#int fa0/24
Switch(config-if)#no switchport      关闭二层端口,这样就可以配置IP地址了 
Switch(config-if)#ip add 192.168.5.1 255.255.255.0     它现在是一个三层端口,它可以配置IP地址
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#ip routing     开启路由功能,如果不开启路由功能就不能使用路由协议
Switch(config)#router rip     我们这里运行一个rip协议
Switch(config-router)#ver 2
Switch(config-router)#no au
Switch(config-router)#net 192.168.1.0
Switch(config-router)#net 192.168.2.0
Switch(config-router)#net 192.168.3.0


Switch(config-router)#net 192.168.5.0
Switch(config-router)#exit
Switch(config)#
我们现在去路由器上面来看看它的配置。
Router(config)#int fa0/0
Router(config-if)#ip add 192.168.5.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int s0/0
Router(config-if)#ip add 202.1.1.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#ver 2


Router(config-router)#no au
Router(config-router)#net 192.168.5.0
Router(config-router)#default-information originate 它的作用是给我们三层路由器分配一条默认路由出去!
Router(config-router)#exit
Router(config)#
我们在我们的路由器上面查看一下我们的路由表。
Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
R    192.168.1.0/24 [120/1] via 192.168.5.1, 00:00:17, FastEthernet0/0
R    192.168.2.0/24 [120/1] via 192.168.5.1, 00:00:17, FastEthernet0/0
R    192.168.3.0/24 [120/1] via 192.168.5.1, 00:00:17, FastEthernet0/0

C    192.168.5.0/24 is directly connected, FastEthernet0/0
Router#
我们可以看见上面三条是我们在三层交换机上面配置的SVI接口。我们在PC0上面再来测试一下看看能够ping通我们的路由器呢?
image
我们可以看见,能够正常访问我们的路由器,那我们在路由器上面来做NAT访问我们的ISP以及公网的WWW服务器。
Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255

Router(config)#access-list 1 permit 192.168.2.0 0.0.0.255
Router(config)#access-list 1 permit 192.168.3.0 0.0.0.255
Router(config)#ip nat inside source list 1 interface s0/0 overload
Router(config)#int s0/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip nat inside
Router(config-if)#end
Router(config)#ip route 0.0.0.0 0.0.0.0 s0/0
以上这几条是允许192.168.1.0/24、192.168.2.0/24、192.168.3.0/24这三个网段可以通过NAT出去。
我们现在把ISP端配置起来!
Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host ISP
ISP(config)#int s0/0
ISP(config-if)#ip add 202.1.1.2 255.255.255.0
ISP(config-if)#no shut
ISP(config-if)#clock rate 64000
ISP(config-if)#exit
ISP(config)#int fa0/0
ISP(config-if)#ip add 202.1.2.1 255.255.255.0
ISP(config-if)#no shut
ISP(config-if)#exit
ISP(config)#
下面我们来看看ISP端的WWW服务器的IP地址。
image
好了,我们现在基本上配置都完成了。我们去PC0上面来测试一下看看。
image
image
看看我们现在能够正常访问我们的ISP端的WWW服务器。
( 文/ltyluck )
关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明