192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

一个OSPF路由汇总的配置实例实验

发布时间:2013-01-05 12:32

  A配置基本IP地址
  B配置OSPF路由协议
  C汇总前验证OSPF路由协议
  D配置OSPF路由协议的汇总
  E汇总后验证OSPF路由协议
  F验证OSPF路由协议的汇总
  本人个人经验所写,有误的话请愿谅。

  A 配置基本IP地址
  A:A>
  A>enable
  A#config terminal
  A(config)#interface ethernet 1/0
  A(config-if)#ip address 172.16.20.9 255.255.255.248
  A(config-if)#no shutdown
  A(config-if)#interface ethernet 1/1
  A(config-if)#ip address 172.16.20.129 255.255.255.248
  A(config-if)#no shutdown
  A(config-if)#interface ethernet 1/2
  A(config-if)#ip address 172.16.20.161 255.255.255.248
  A(config-if)#no shutdown
  A(config-if)#interface ethernet 1/3
  A(config-if)#ip address 172.16.20.145 255.255.255.248
  A(config-if)#no shutdown
  B:
  B>
  B>enable
  B#config terminal
  B(config)#interface ethernet 1/0
  B(config-if)#ip address 172.16.20.10 255.255.255.248
  B(config-if)#no shutdown
  C:
  C>
  C>enable
  C#config terminal
  C(config-if)#interface ethernet 1/0
  C(config-if)#ip address 172.16.20.130 255.255.255.248
  C(config-if)#no shutdown
  D:
  D>
  D>enable
  D#config terminal
  D(config-if)#interface ethernet 1/0
  D(config-if)#ip address 172.16.20.161 255.255.255.248
  D(config-if)#no shutdown
  E:
  E>
  E>enable
  E#config terminal
  E(config-if)#interface ethernet 1/0
  E(config-if)#ip address 172.16.20.146 255.255.255.248
  E(config-if)#no shutdown
  B 配置OSPF路由协议
  A:
  A(config)#router OSPF 100                                     *这是进程号,可自己定的,但都得一样,我这是100*
  A(config-router)#network 172.16.20.8 0.0.0.7 area 1
  A(config-router)#network 172.16.20.128 0.0.0.7 area 0         *这里的area 0 和area 1 是区域号,注意的是一定要有area 0,其它可以自己定,但都得一样*
  A(config-router)#network 172.16.20.160 0.0.0.7 area 0
  A(config-router)#network 172.16.20.144 0.0.0.7 area 0
  B:
  B(config)#router ospf 100                                     *这是进程号,可自己定的但都得一样,我这是100*
  B(config-router)#network 172.16.2.8 0.0.0.7 area 1
  C:
  C(config)#router OSPF 100
  C(config-router)#network 172.16.20.128 0.0.0.7 area 0
  D:
  D(config)#router OSPF 100                                      *这是进程号,可自己定的但都得一样,我这是100*
  D(config-router)#network 172.16.20.160 0.0.0.7 area 0
  E:
  C(config)#router OSPF 100                                      *这是进程号,可自己定的但都得一样,我这是100*


  C(config-router)#network 172.16.20.144 0.0.0.7 area 0
  C 汇总前验证OSPF路由协议
  可以用SHOW IP ROUTE 这个命令,验证EIGRP路由协议.这里不说了,可以去看我以前的.
  D 配置OSPF路由协议的汇总
  A:
  A(config)#router ospf 100                                      *这是进程号,可自己定的但都得一样,我这是100*
  A(config-if)#area 0 range 172.16.20.128 255.255.255.192        *这是汇总命令*
  D:
  D(config)#router OSPF 100                                      *这是进程号,可自己定的但都得一样,我这是100*
  D(config-router)#summary-adress 172.16.20.0 255.255.255.0      *这是汇总命令*
  E 汇总后验证OSPF路由协议
  可以用SHOW IP ROUTE 这个命令,验证EIGRP路由协议.看前后两次路由表的变化.
  F 验证OPSPF路由协议的汇总

用路由器B去PING所有的IP,能通就成功了,呵呵。ping不通的话,说明那有问题,要检查硬件的和其它配置了。

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明