192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

演示:OSPF的邻居关系故障分析与排除

发布时间:2014-02-24 08:42

故障背景:如图14.14所示的OSPF路由环境,如产生故障的原始配置所示,每台路由器都配置并启动了OSPF路由协议,由于某些特殊原因将R1的S2/0接口的MTU配置成1492;然后路由器R1、R2、R3都出现了OSPF邻居故障,在三台路由器上查看它们的邻居关系时,出现如图14.15所示,可看出路由器R1与R2的邻居关系停滞在Exstart(准启动)状态,而路由器R2和R3停滞2way(双向状态),请查明原因,并排除故障。

产生故障的原始配置:每台路由器的原始配置如下所示。

路由器R1的原始配置:
interface Loopback1
ip address 192.168.4.1 255.255.255.0
!
interface Serial2/0
mtu 1492
ip address 192.168.1.1 255.255.255.252
encapsulation ppp
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 192.168.1.0 0.0.0.3area 0
network 192.168.4.0 0.0.0.255area 0

路由器R2原始配置:
interfaceEthernet1/0
ip address 192.168.2.1 255.255.255.0
ip ospfpriority 0
duplex half
!
interface Serial2/0
ip address 192.168.1.2 255.255.255.252
encapsulation ppp
serial restart-delay 0
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 192.168.1.0 0.0.0.3area 0
network 192.168.2.0 0.0.0.255area 0

路由器R3原始配置:
interface Loopback1
ip address 192.168.5.1 255.255.255.0
!
interfaceEthernet1/0
ip address 192.168.2.2 255.255.255.0
ip ospfpriority 0
duplex half
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 192.168.2.0 0.0.0.255area 0
network 192.168.5.0 0.0.0.255area 0

故障分析:在确定没有为网络设备配置错误的地址或者漏配以后,可以通过Debug工具来调试OSPF的运行状态,在路由器R1执行debugip ospf adj指令,得到如图14.16所示,指示路由器R1正收到2.2.2.2(R2)发来的一个较大的接口MTU值,然后通过在路由器R1和R2上执行showinterface s2/0查看接口的MTU值,如图14.17所示,由于两台路由器相邻接口的MTU值不匹配,是邻居关系停滞在准启动状态的关键原因,这种故障在实际的工作环境中往往发生在一条链路穿过不同介质类型的二层网络中,OSPF的邻居协商会检测同一链路的MTU值是否一致。排除故障的方案就是在路由器R1的S2/0接口上配置ip ospfmtu-ignore指令忽略MTU检测。然后在路由器R3上再次执行debugip ospf adj指令,得到如图14.18所示,指示路由器R2和R3都没有参加DR与BDR的选举,所以它们的邻居关系停滞在双向状态,认真查看路由器R2和R3的原始配置不难发现,它们的E1/0接口都配置了OSPF的优先级为0,这样将导致两台路由器都不会参加DR与BDR的选举,所以它们被停滞在双向状态,解决这个故障的方案是配置一台路由器具备较高的OSPF优先级,并成为DR路由器。关于具体的故障排除的解决的配置过程请参看解决方案部分。

wKioL1MKaAyRGI2QAAFVnPJdiPk761.jpg
wKiom1MKaDLwbS8MAAGubPvniDI858.jpg
wKioL1MKaA2y9lgzAAJVpGVoDI0956.jpg
关于部分导致OSPF邻居形成的故障可能性:
n路由器接口上没有启动OSPF。
n物理层和数据链路层故障。
n某种行为阻止了OSPF hello数据包。
nHello间隔、死亡间隔时间不匹配。
n验证类型、验证密钥不匹配。
n区域号不匹配。
n在多路访问的链路上两台邻接路由器的IP地址与子网掩码不匹配。
n所有路由器的OSPF优先级都被设置为0,这将使邻居停滞在双向状态。
n在帧中继环境中使用fame-relay map语句时没有加上broadcast关键字。
nMTU不匹配可导致OSPF邻居停滞在准启动状态。
n重复的路由器ID(RID)可导致OSPF邻居停滞在准启动状态。

解决方案:
R1(config)#interfaces2/0
R1(config-if)#ip ospfmtu-ignore* 让OSPF忽略MTU检测。

R3(config)#interfacee1/0
R3(config-if)#ip ospf priority 254* 配置R3的OSPF优先级。

当完成上述的故障解决方案配置后,可得到如图14.19所示的OSPF邻居表,一切正常,故障成功的被排除。

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明