192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

静态路由与VTP的实现思路和配置命令行

发布时间:2014-10-13 10:25

思路:在不同路由器相互连接接口Ip配置为同一网段,而路由器内部之间接口则通过直连路由实现通信。路由器添加的静态路由为要通信的路由器的接口ip和子网掩码以及路由器直连的路由器的接口ip地址!也即下一跳地址。

组网连接: PC2 - Router2 - Router3 - Router4 - Router5 - PC3

Router-1
Router>en
Router#conf t
R1(config)#int f0/1
R1(config-if)
#R1(config-if)#ip add 1.1.1.2 255.0.0.0
R1(config-if)#no shut
R1(config-if)#int f0/0
R1(config-if)#ip add 2.2.2.1 255.0.0.0
R1(config-if)#no shut

##############################
Router-2
Router>en
Router#conf t
Router(config)#host R2
R2(config)#int f0/0
R2(config-if)#ip add 2.2.2.2 255.0.0.0
R2(config-if)#int f0/1
R2(config-if)#ip add 3.3.3.1 255.0.0.0
R2(config-if)#no shut

##############################
Router-3
Router>en
Router#conf t
Router(config)#host R3
Router(config)#int f0/1
Router(config-if)#ip add 3.3.3.2 255.0.0.0
Router(config-if)#no shut
R3(config-if)#int f0/0
R3(config-if)#ip add 4.4.4.1 255.0.0.0
R3(config-if)#no shut
在R1中添加静态路由
R1(config)#ip route 3.0.0.0 255.0.0.0 2.2.2.2
R1(config)#ip route 4.0.0.0 255.0.0.0 2.2.2.2
在R2中添加静态路由
R2(config)#ip route 1.0.0.0 255.0.0.0 2.2.2.1
R2(config)#ip route 4.0.0.0 255.0.0.0 3.3.3.2
在R3中下方一条默认路由
R3(config)#ip route 0.0.0.0 0.0.0.0 3.3.3.1
查看路由信息do show  ip route


¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥¥

思路:VTP用来管理交换机之间的Vlan,一共三种模式:服务器模式(server)、客户机模式(clients)、透明模式(transparent),服务端设置好Vlan,客户机不能删除修改Vlan,能自动同步Vlan信息,透明端不受影响,可以自身添加Vlan、删除Vlan,只起一个中继传输作用。交换机与交换机之间通信同过trunk来进行传输。

1.设置主机名

(conf)#hostname sw1

2.配置enable密码

(conf)#enable password 123     ---明文密码

(conf)#enable secret  456       --加密密码

3.配置控制线的密码

(conf)#line console 0
(config-line)#password 123
(config-line)#login

4.配置远程管理(vty)
  (1).设备配置一个管理ip(vlan1接口)
SW1(config)#interface vlan 1
SW1(config-if)#ip address 192.168.1.1 255.255.255.0
SW1(config-if)#no shutdown
SW1(config-if)#exit

SW1(config)#line vty 0 4
SW1(config-line)#password 123456
SW1(config-line)#login

查询配置文件
#show running-config
保存配置文件
SW1#copy running-config startup-config      等于SW1#write
Destination filename [startup-config]?
Building configuration...
[OK]
验证
SW1(config)#end
SW1#exit

User Access Verification

Password:123 (console密码)

SW1>enable  (特权密码)
Password:

打开命令提示符,给pc配置一个ip(192.168.1.2)

PC>telnet 192.168.1.1
Trying 192.168.1.1 ...Open

User Access Verification

Password: (远程vty密码)
SW1>

划分vlan

1.创建vlan
Switch(config)#hostname sw1

sw1(config)#vlan 10--在全局创建vlan10
sw1(config-vlan)#name UPL_VLAN10--给vlan10取名

sw1#vlan database --进入vlan数据库

sw1(vlan)#vlan 20--创建vlan20
VLAN 20 added:
    Name: VLAN0020
sw1(vlan)#exit
APPLY completed.
Exiting....

sw1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
sw1(config)#vlan 20
sw1(config-vlan)#name UPL_VLAN20    --进入全局给vlan20重命名

sw1(config)#do show vlan      --查询vlan


2.将端口划分vlan中,实现隔离广播

sw1(config)#interface f0/1
sw1(config-if)#switchport access vlan 10
sw1(config)#interface f0/2
sw1(config-if)#switchport access vlan 10

sw1(config)#interface range f0/3-4
sw1(config-if-range)#switchport access vlan 20

+++++++++++++++++++
配置vlan truck

Switch>
Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname sw1

sw1(config)#vlan 100
sw1(config-vlan)#vlan 200
sw1(config-vlan)#vlan 300
sw1(config-vlan)#do show vlan

sw1(config)#vlan 100
sw1(config-vlan)#vlan 200
sw1(config-vlan)#vlan 300
sw1(config-vlan)#do show vlan

sw1(config)#interface ra f0/1-10 
sw1(config-if-range)#switchport mode access
sw1(config-if-range)#switchport access vlan 100

sw1(config)#interface range f0/11-20
sw1(config-if-range)#switchport mode access
sw1(config-if-range)#switchport access vlan 200

sw1(config)#interface range f0/21-23
sw1(config-if-range)#switchport mode access
sw1(config-if-range)#switchport access vlan 300

配置中继

给中继封装协议
sw1(config-if)#switchport trunk encapsulation dot1q
sw1(config-if)#switchport trunk encapsulation dot1q
sw1(config-if)#switchport mode trunk

+++++++++++++++++++++++

VTP

Switch>
Switch>en
Switch#conf t  http://www.luyouqiwang.com/17685
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname sw1
sw1(config)#vtp mode server
sw1(config)#vtp mode server
sw1(config)#vtp password 123
sw2(config)#vtp mode transparent
sw2(config)#vtp domain UPL
sw2(config)#vtp password 123
Switch(config)#hostname sw3
sw3(config)#vtp mode client
sw3(config)#vtp domain UPL
sw3(config)#vtp password 123

所有中继链路需要打成truck
sw1(config-vlan)#int f0/1
sw1(config-if)#switchport mode trunk
sw2(config)#int ra f0/1-2
sw2(config-if-range)#switchport mode trunk
sw3(config)#int f0/2
sw3(config-if)#switchport mode trunk

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明