192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

记录一次完整的paramiko安装过程

发布时间:2015-02-08 12:27

 最近要在本地获取远程服务器上的实时日志信息,想到了采用paramiko模块来获取远程机器上的内容。

所以,第一步就是要安装paramiko这个模块的信息:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
C:\Users\shuidiyou>easy_install paramiko
Searching for paramiko
Best match: paramiko 1.15.2
Processing paramiko-1.15.2-py2.7.egg
paramiko 1.15.2 is already the active version in easy-install.pth
Using c:\python27\lib\site-packages\paramiko-1.15.2-py2.7.egg
Processing dependencies for paramiko
Searching for pycrypto>=2.1,!=2.4
Reading https://pypi.python.org/simple/pycrypto/
Best match: pycrypto 2.6.1
Downloading https://pypi.python.org/packages/source/p/pycrypto/pycrypto-2.6.1.ta
r.gz#md5=55a61a054aa66812daf5161a0d5d7eda
Processing pycrypto-2.6.1.tar.gz
Writing c:\users\shuidi~1\appdata\local\temp\easy_install-i4vgct\pycrypto-2.6.1\
setup.cfg
Running pycrypto-2.6.1\setup.py -q bdist_egg --dist-dir c:\users\shuidi~1\appdat
a\local\temp\easy_install-i4vgct\pycrypto-2.6.1\egg-dist-tmp-o0ukxk
warning: GMP or MPIR library not found; Not building Crypto.PublicKey._fastmath.
error: Setup script exited with error: Unable to find vcvarsall.bat

可以看到最后的报错信息:Unable to find vcvarsall.bat

 

百度+google之,给出了两种解决方案

1、安装visual c++ 2008 express

    可这玩意老鬼大了,而且在费尽心思下载完安装后,此问题还在

2、安装MinGW

    PS:MinGW分为较早开发的MinGW32和之后为编译64位程序开发的MinGW-w64,MinGW32只能编译32位的程序,而mingw64不仅能编译            64位程序,也能编译32位程序,还能进行交叉编译,即在32位主机上编译64位程序,在64位主机上编译32位程序。

    所以就直接下载mingw64来安装

    链接地址:http://sourceforge.net/projects/mingw-w64/?source=typ_redirect

    这下载后其实只是个下载工具,运行后还会在进行一次下载安装。

    之可惜,在完全下载安装完后,把mingw的路径添加到系统的环境变量后,以上的错误仍然存在。


之后又google+百度之,在查看错误信息时,有一条错误提示有明显的提示

warning: GMP or MPIR library not found; Not building Crypto.PublicKey._fastmath.


用这个信息去查找,发现重要信息。

paramiko模块又依赖于pycrypto模块,所以要安装paramiko先安装pycrypto模块

这个模块网上有现成编译好的文件,直接下载安装后就可以(要找到对应的版本)

http://www.voidspace.org.uk/python/modules.shtml#pycrypto

安装完后,在重新使用easy_install 安装paramiko模块


这次大功告成

1
2
3
4
5
6
7
8
C:\Users\shuidiyou>easy_install paramiko
Searching for paramiko
Best match: paramiko 1.15.2
Processing paramiko-1.15.2-py2.7.egg
paramiko 1.15.2 is already the active version in easy-install.pth
Using c:\python27\lib\site-packages\paramiko-1.15.2-py2.7.egg
Processing dependencies for paramiko
Finished processing dependencies for paramiko

 

正常导入

1
2
3
4
5
6
C:\Users\shuidiyou>python
Python 2.7.7 (default, Jun  1 2014, 14:17:13) [MSC v.1500 32 bit (Intel)] on win
32
Type "help""copyright""credits" or "license" for more information.
>>> import paramiko
>>>
关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明