192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

华为AR系列路由器静态路由协议配置方法

发布时间:2015-04-11 11:27

静态路由协议就是静态路由,要把网络中每一条路由手动配置,下面诚恺科技小编就以华为路由器为例,同大家一起来看看IPv4静态路由、NQA for IPv4静态路由、IPv6静态路由的详细配置方法,供大家参考。

一、配置IPv4静态路由基本功能示例

组网需求

路由器各接口及主机的IP地址和掩码如图1所示。要求采用静态路由,使图中任意两台主机之间都能互通。

图1 配置静态路由组网图

 

操作步骤

1.RouterA的配置

#

interface GigabitEthernet1/0/0

ip address 10.1.1.1 255.255.255.0

interface GigabitEthernet2/0/0

ip address 10.1.4.1 255.255.255.252

#

ip route-static 10.1.2.0 255.255.255.0 10.1.4.2                              

ip route-static 10.1.3.0 255.255.255.0 10.1.4.2  //配置RouterA到不同网段的静态路由 

return

2.RouterB的配置

#

interface GigabitEthernet1/0/0

ip address 10.1.2.1 255.255.255.0

interface GigabitEthernet2/0/0

ip address 10.1.4.2 255.255.255.252

#

interface GigabitEthernet3/0/0

ip address 10.1.4.5 255.255.255.252

#

ip route-static 10.1.1.0 255.255.255.0 10.1.4.1                              

ip route-static 10.1.3.0 255.255.255.0 10.1.4.6  //配置RouterB到不同网段的静态路由          # 

return

3.RouterC的配置

#

interface GigabitEthernet1/0/0

ip address 10.1.3.1 255.255.255.0

interface GigabitEthernet2/0/0

ip address 10.1.4.6 255.255.255.252

#

ip route-static 10.1.1.0 255.255.255.0 10.1.4.5                              

ip route-static 10.1.2.0 255.255.255.0 10.1.4.5  //配置RouterC到不同网段的静态路由

return

4.配置主机

配置VLAN10内主机的缺省网关为10.1.1.1,VLAN20内主机的缺省网关为10.1.3.1,VLAN30内主机的缺省网关为10.1.2.1。

5.配置交换机

配置各交换机,使得各主机能与其网关路由器互通。

6.检查配置结果

使用display ip routing-table命令查看路由器的IP路由表。

使用Ping命令验证连通性。

配置注意事项

——正确配置各路由器各接口的IPv4地址,使网络互通。

——保证两个路由器互连接口地址配置在同一网段,并且可以正常互通。

——在各主机上配置IPv4缺省网关。

二、配置NQA for IPv4静态路由示例

组网需求

通过配置NQA for IPv4静态路由可以快速检测到网络的故障,控制静态路由的发布。如图2所示,RouterA通过接口GE2/0/0连接RouterB到RouterD作为主链路,RouterA通过接口GE1/0/0连接RouterC到RouterD作为备份链路。在RouterA上配置NQA ICMP测试例,以检测主链路的网络状况。当主链路出现故障时,从RouterA发送到RouterD的报文就会切换到备份链路进行转发。

图2 配置NQA for IPv4静态路由组网图

 

操作步骤

1.RouterA的配置

#

sysname RouterA

#

interface GigabitEthernet1/0/0

ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet2/0/0

ip address 192.168.4.1 255.255.255.0

#

interface GigabitEthernet3/0/0

ip address 192.168.6.1 255.255.255.0

#

ip route-static 192.168.2.0 255.255.255.0 192.168.1.2

ip route-static 192.168.3.0 255.255.255.0 192.168.4.2

ip route-static 192.168.5.0 255.255.255.0 192.168.1.2 preference 100  //配置静态路由优先级为100,用来做备用路由

ip route-static 192.168.5.0 255.255.255.0 GigabitEthernet2/0/0 192.168.4.2 track nqa admin icmp  //配置与NQA测试例联动的静态路由

#

nqa test-instance admin icmp  //配置名为admin icmp的NQA测试例

test-type icmp  //配置测试例类型为ICMP

destination-address ipv4 192.168.3.1  //配置NQA测试例的目的地址为192.168.3.1

frequency 10  //配置NQA测试例两次测试之间间隔10秒

probe-count 2  //配置NQA测试例的测试探针数目为2

start now  //立即开始执行当前的NQA测试例

#

2.RouterB的配置

#

sysname RouterB

#

interface GigabitEthernet1/0/0

ip address 192.168.3.2 255.255.255.0

#

interface GigabitEthernet2/0/0

ip address 192.168.4.2 255.255.255.0

#

ip route-static 192.168.5.0 255.255.255.0 192.168.3.1

ip route-static 192.168.6.0 255.255.255.0 192.168.4.1

#

3.RouterC的配置

#

sysname RouterC

#

interface GigabitEthernet1/0/0

ip address 192.168.1.2 255.255.255.0

#

interface GigabitEthernet2/0/0

ip address 192.168.2.1 255.255.255.0

#

ip route-static 192.168.5.0 255.255.255.0 192.168.2.2

ip route-static 192.168.6.0 255.255.255.0 192.168.1.1

#

4.RouterD的配置

#

sysname RouterD

#

interface GigabitEthernet1/0/0

ip address 192.168.3.1 255.255.255.0

#

interface GigabitEthernet2/0/0

ip address 192.168.2.2 255.255.255.0

#

interface GigabitEthernet3/0/0

ip address 192.168.5.1 255.255.255.0

#

ip route-static 192.168.1.0 255.255.255.0 192.168.2.1

ip route-static 192.168.4.0 255.255.255.0 192.168.3.2

ip route-static 192.168.6.0 255.255.255.0 192.168.3.2

ip route-static 192.168.6.0 255.255.255.0 192.168.2.1

#

5.检查配置结果

在RouterA上执行命令display nqa results test-instance admin icmp查看NQA测试结果,其中可以看到“Lost packet ratio: 0 %”,这说明链路状态完好。然后执行命令display ip routing-table查看路由表,可以看到到目的网段192.168.5.0/24,下一条为192.168.4.2的静态路由存在于路由表中,而配置的优先级为100的静态路由不存在与路由表中。

在RouterB的两个接口的任一接口视图下执行命令shutdown,来模拟链路出现故障。然后在RouterA上执行命令display nqa results test-instance admin icmp,查看NQA测试结果,其中可以看到“Completion:failed”和“Lost packet ratio: 100 %”,这说明检测到链路出现故障。接着执行命令display ip routing-table查看路由表,可以看到之前到目的网段192.168.5.0/24,下一条为192.168.4.2的静态路由被优先级为100的静态路由在路由表中所取代。

配置注意事项

——NQA测试例使用display nqa results命令查看测试结果,只有当测试完成状态为测试失败时,与NQA联动的静态路由才会在路由表中被删除。

——修改NQA测试例的配置时,要先停止当前运行的NQA测试例。

——配置同一条静态路由与其它NQA测试例联动时,会解除与当前NQA测试例的联动关系。

——此案例中的NQA仅做PING检测,对对端设备没有配置要求。目的是让RouterA通过检测结果来切换链路,从而增强RouterA对报文转发的可靠性。

三、配置IPv6静态路由基本功能示例

组网需求

路由器各接口及主机的IPv6地址和掩码如图3所示。要求采用静态路由,使图中任意两台主机之间都能互通。

图3 配置IPv6静态路由组网图

 

操作步骤

1.RouterA的配置

#

ipv6  //使能路由器IPv6报文转发能力

#

interface GigabitEthernet1/0/0

ipv6 enable  //在接口上使能IPv6功能

ipv6 address 1::1 64

interface GigabitEthernet2/0/0

ipv6 enable

ipv6 address 2::2 64

#

ipv6 route-static 3:: 64 2::1                              

ipv6 route-static 4:: 64 2::1                              

ipv6 route-static 5:: 64 2::1  //配置RouterA到不同网段的静态路由 

return

2.RouterB的配置

#

ipv6

#

interface GigabitEthernet1/0/0

ipv6 enable

ipv6 address 3::1 64

interface GigabitEthernet2/0/0

ipv6 enable

ipv6 address 2::1 64

#

interface GigabitEthernet3/0/0

ipv6 enable

ipv6 address 4::1 64

#

ipv6 route-static 1:: 64 2::2                              

ipv6 route-static 5:: 64 4::2

return

3.RouterC的配置

#

ipv6

#

interface GigabitEthernet1/0/0

ipv6 enable

ipv6 address 5::1 64

interface GigabitEthernet2/0/0

ipv6 enable

ipv6 address 4::2 64

#

ipv6 route-static 1:: 64 4::1                              

ipv6 route-static 2:: 64 4::1                              

ipv6 route-static 3:: 64 4::1

return

4.配置主机

配置VLAN10内主机的缺省网关为1::1,VLAN20内主机的缺省网关为5::1,VLAN30内主机的缺省网关为3::1。

5.配置交换机

配置各交换机,使得各主机能与其网关路由器互通。

6.检查配置结果

使用display ipv6 routing-table命令查看路由器的IP路由表。

使用Ping ipv6命令验证连通性。

配置注意事项

——配置IPv6路由协议前,一定要先使能路由设备转发IPv6单播报文。在接口下配置关于IPv6特性的命令前必须先在接口上使能IPv6功能。

——正确配置各路由器各接口的IPv6地址,使网络互通。

——在各主机上配置缺省网关。

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明