192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

帧中继和路由协议详解-在帧中继物理接口上运行EIGRP

发布时间:2015-05-22 09:41

 环境介绍:

  • 本实验环境采用GNS3软件进行模拟。

  • 两个站点都启用EIGRP路由协议,自治系统号100。

  • R1和R2分别模拟站点1和站点2的点对点路由器。

  • R1的环回口LO1:1.1.1.1/24模拟站点1的内网;R2的环回口LO1:2.2.2.2/24模拟站点2的内网.

  • R1(DTE)和站点1本局帧中继交换机(DCE)对接的接口为S1/0,配置的IP地址为12.12.12.1/30;R2(DTE)和站点2本局帧中继交换机(DCE)对接的接口为S1/0,配置的IP地址为12.12.12.2/30.

  • DLCI:101模拟ISP给站点1分配的数据链路标识符;DLCI:202模拟ISP给站点2分配的数据链路标识符。

  • 帧中继网络用GNS3自带的“Frame relay switch(帧中继交换机)”,下面用FR1表示。这里需要说明的是,在真实环境中帧中继网络是不需要我们搭建和配置的,我们只需要让ISP提供给我们DLCI号码和本地最近的帧中继交换机接口并告知LMI封装类型就可以了。

 

实验目的:

  • 让站点1的路由器R1能够学习到站点2的内部网络2.2.2.2/24的路由条目,R2亦然。

  • 让R1和R2各自的内部网络能够互相PING通。

  • 在学会配置的同时明白EIGRP路由协议在帧中继物理口点对点连接的工作原理。

实验步骤:

帧中继交换机的初始化配置:

 

上面表示站点1分配的DLCI号为101连接的物理接口为1;站点2分配的DLCI号为202连接的物理接口为10.

注意:真实环境中不需要用户搭建和配置,并却DLCI 101和202之间的帧中继虚链路也是由ISP来配置实现的。

路由器R1的配置:

interface Loopback1   
ip address 1.1.1.1 255.255.255.0

interface Serial1/0   
ip address 12.12.12.1 255.255.255.252    
encapsulation frame-relay //封装帧中继类型,有CISCO和IETF,这里配置为默认CISCO     


no shutdown

router eigrp 100 //启用EIGRP路由协议AS为100       
network 0.0.0.0 //宣告所有接口    


 

路由器R2的配置:

interface Loopback1   
ip address 2.2.2.2 255.255.255.0

interface Serial1/0   
ip address 12.12.12.2 255.255.255.252    
encapsulation frame-relay //封装帧中继类型,有CISCO和IETF,这里配置为默认CISCO    
no shutdown

router eigrp 100 //启用EIGRP路由协议AS为100    
network 0.0.0.0 //宣告所有接口    
 

验证:

查看DLCI

R1#show frame-relay map //在R1上查看DLCI映射表   
Serial1/0 (up): ip 12.12.12.2 dlci 101(0x65,0x1850), dynamic, //12.12.12.2为站点2对端的IP地址,dlci 101为站点1本局的dlci号,IP地址+dlci的意思就是凡是发给ip地址为12.12.12.2(R2)的数据包通通发到dlci编号为101的帧中继交换机接口傻瓜你。dynamic表示通过动态学到的,后面再介绍静态配置的。

broadcast,, status defined, active //broadcast表示该网络可以传播广播包(MA)点对点链路上可以传播广播包,status defined,active表示和所连接的帧中继交换机的LMI状态为活动的!

查看路由表

R1#show ip route eigrp    
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks    
D       1.0.0.0/8 is a summary, 00:28:53, Null0    
D    2.0.0.0/8 [90/2297856] via 12.12.12.2, 00:17:37, Serial1/0    


     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks    
D       12.0.0.0/8 is a summary, 00:28:53, Null0

R2#show ip route eigrp    
D    1.0.0.0/8 [90/2297856] via 12.12.12.1, 00:20:23, Serial1/0    
     2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks    
D       2.0.0.0/8 is a summary, 00:18:32, Null0    
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks    
D       12.0.0.0/8 is a summary, 00:18:33, Null0

连通性

R1#ping 2.2.2.2

Type escape sequence to abort.   
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:    
!!!!!    
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/69/88 ms

R2#ping 1.1.1.1

Type escape sequence to abort.   
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:    
!!!!!    
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/75/84 ms

注意事项:    

  • 确保R1和R2的两个点对点接口所配的IP地址在同个子网里。

  • 动态映射是iARP,默认启用,而且总是允许伪广播(不可控)。    
     

  • frame-relay map ip 地址 dlci 值,一般用在物理接口和多点子接口上配置的,表示某IP(对端)与某DLCI(本端)对应,与ip和MAC对应的道理是类似的。

  • frame-relay interface-dlci,一般用在点到点子接口上的,表示不管IP(对端)是什么,都和该DLCI(本端)对应。

本篇就介绍到此,下篇开始介绍子接口下的帧中继点对点配置EIGRP和静态的DLCI映射表!

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明