192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

帧中继和路由协议详解-在帧中继多点子接口上运行EIGRP

发布时间:2015-05-24 10:09

    上一篇我们介绍了《帧中继和路由协议详解-在帧中继点到点子接口上运行EIGRP》,本篇我们开始介绍《在帧中继多点子接口上运行EIGRP》的配 置。相关概念,如子接口、IARP、DLCI和映射等已经在前一篇提过,本篇不再详述,有疑问的地方可以自行参考。本篇侧重配置上的问题。

背景

    当有多个分部的局域网通过帧中继和总部想实现两两互联时,为了减少对总部路由器接口的占用和对应的线路费用,通常采用多个分部的同一网段用不同虚电路连接到总部局的同一局域网的方法来实现总部和分部的互联。如下图1, 三个路由器采用点到多点的帧中继连接,假如R1是总部的路由器,为了实现和R2、R3互联,我们需要在R1的S0/0口划分一个子接口S0/0.1。S0/0.1对应 的DLCI地址分别为为102和103,与R2的S0口建立了虚电路对应的DLCI地址为201,与R3的S0口建立了虚电路对应的DLCI地址为301。各个路由 器使用EIGRP协议学习路由。ISP的帧中继封装类型为CISCO。

 

注意:

    在多点帧中继网络中,应关闭水平分割,否则同一接口映射的多个路由器不能交换路由。这是一个特殊情况,绝大多数情况下还是应该打开水平分割的。水平分割不允许路由器把从一个接口收到的路由更新从该接口发出去。子接口都默认是启用水平分割的,多点子接口跑EIGRP要关闭水平分割。

    以上面的图1为例:R2把身后的网段2.2.2.0/24传给R1的子接口S0/0.1,如果没有在S0/0.1上关闭水平分割的话,S0/0.1在收到R2的更新后就不会再从收到路由更新的接口(这里为S0/0.1)重新以多播的形式发送出去。这样2.2.2.0/24的路由条目无法从R1传给R3,R3 自然就学不到2.2.2.0/24的路由信息,最后导致R2无法和R3通讯。R3同理!

    也许你会想,如果禁用了S0/0.1的水平分割的话,R3在收到R1传来更新的同时,R2岂不是也会收到R1重新发回来的路由更新条,目从而导致环路。这个不用担心,因为EIGRP在发送更新前会有个最优和次优路径的机制,所以R2发给R1的更新,R1是不会再发回给R2的!

配置

R1的配置

R1(config)#interface s0/0.1 multipoint //指定子接口并配置为多点类型
 

R1(config-subif)#frame-relay map ip 123.123.123.2 102 broadcast //配置静态DLCI表,表示发给IP地址为123.123.123.2的数据直接扔给本地DLCI为102的接口即可并且允许伪广播(多个单播帧的copy)。
 

R1(config-subif)#frame-relay map ip 123.123.123.3 103 broadcast 
 

R1(config-subif)#ip address 123.123.123.1 255.255.255.0 //为子接口配置IP地址。
 

R1(config-subif)#no ip split-horizon eigrp 100 //禁用水平分割
 

R1(config)#inter s0/0

R1(config)#no ip address

R1(config)#encapsulation frame-relay //配置封装类型为帧中继


 

R1(config-if)#no shutdown //开启物理接口
 

R1(config)#inter f1/0

R1(config-if)#ip add 1.1.1.1 255.255.255.0

R1(config-if)#no shut

R1(config)#router eigrp 100

R1(config-router)#net 0.0.0.0

R2的配置

interface Serial0/0

    ip address 123.123.123.2 255.255.255.0

    encapsulation frame-relay

    no ip split-horizon eigrp 100

    frame-relay map ip 123.123.123.1 201 broadcast

interface FastEthernet1/0

    ip address 2.2.2.1 255.255.255.0

    no shutdown
 

router eigrp 100

    network 0.0.0.0

R3的配置

interface Serial0/0

    ip address 123.123.123.3 255.255.255.0

    encapsulation frame-relay

    no ip split-horizon eigrp 100

    serial restart-delay 0

    frame-relay map ip 123.123.123.1 301 broadcast

!

interface FastEthernet1/0

    ip address 3.3.3.1 255.255.255.0

    no shutdown
 

router eigrp 100

    network 0.0.0.0

验证

 

 

 

查看R1的邻居:

 

查看,EIGRP路由表:

 

 

 

如果关闭R1子接口S0/0.1下面的水平分割

 

此时会发现R2上已经没有R3后面的路由条目3.0.0.0/8.

 

R3同理,没有了R3后面的路由条目2.0.0.0/8。

 

此时,R2无法PING通R3

 

R3同样也无法PING通R2

 

重新no掉水平分割

 

R2和R3的通讯恢复正常

 

 

好了,本系列就写到这啦!希望大家自己多动手练习练习,不明白的地方给我留言!

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明