192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

路由器+交换机基本命令配置参数

发布时间:2017-05-11 08:29

模式的介绍
用户模式   Router> enable                          只能简单的查看设备
特权模式   R1#config terminal                可以查看所有配置,但不能修改
全局模式   R1(config)#intface Fastehernet0/1   可以对设备进行任意配置,查看
exit:退后一步
end:在任何模式下退回到特权模式(Ctrl+Z快捷键)
disable:特权模式退回用户模式

show MAC-address-table:(后加static静态dynamic动态)记录MAC地址和接口编号的对应关系。
clear MAC-address-table:清除MAC地址表
------------------------------------------------------------------------------------------
双工模式
speed 100 指定接口速率
duplex full 将接口的双工模式指定为全双工
duplex half:将接口的双工模式指定为半双工
duplex auto:将接口的双工模式指定为自动协商
------------------------------------------------------------------------------------------
配置命令时的快捷键
show interface f0/n 查看接口信息
tab键:自动补全命令,不补全一样生效
Ctrl+a,Ctrl+e:光标分别移到命令行的开始或结束位置
hostname:用于配置主机名,比如hostname 你的名字
show version:显示系统ISO名称以及版本信息
?:显示当前模式下所有命令及其命令注解
ctrl+shift+6:快速取消(比如出现255.255.255.255卡很久的情况)
复制:ctrl+insert
粘贴:shitf+insert
-------------------------------------------------------------------------------------------
垃圾命令
abc(config)#no ip domain lookup     关闭DNS查询,不会出255.255.255.255 卡很久的情况
abc(config)#line console 0             进入console接口配置
abc(config-line)#exec-timeout 0 0      永不超时 (默认时间5分钟登出,退回到用户模式)
abc(config-line)#logging synchronous  日志同步,输入时不会被打断
-------------------------------------------------------------------------------------------
Cisco设备ARP命令
show arp 显示ARP缓存表
clear arp-cache 清除ARP缓存表
arp 1.1.1.1 0011.1111.1111 arpa 绑定arp条目
--------------------------------------------------------------------------------------------
静态路由和默认路由的配置命令
ip route 192.168.2.0 255.255.255.0 192.168.2.1 静态路由模式
ip route 0.0.0.0 0.0.0.0 192.168.2.1           默认路由模式
no ip route 0.0.0.0 0.0.0.0 192.168.2.1        清除对应路由表


show ip route           特权模式下查看路由器路由表,必须有一台路由器
do show ip route        其他模式下查看路由器路由表,用户模式除外
-------------------------------------------------------------------------------------------
IP地址配置
配置ip参数 ip add 192.168.1.1 255.255.255.0
no shutdown 开启路由器物理接口
-------------------------------------------------------------------------------------------
配置虚拟PC及其IP参数
SW1(config)#interface lookpack 1
SW1(config)#ip address 192.168.1.1 255.255.255.0
SW1(config)#exit
-------------------------------------------------------------------------------------------
保存配置的命令
show running-config:查看交换机当前全部配置信息,包括已保存和未保存的配置信息
show startup-config:只显示已保存的配置信息
copy running-config startup-config:保存当前配置信息
copy startup-config running-config:修改寄存器值的情况下加载以前配置信息比如可以查看以前密码
write:保存当前配置信息
erase nvram:删除已保存的配置信息(禁止使用)
-------------------------------------------------------------------------------------------
配置密码和恢复密码的命令
R1(config)#enable password 123  明文密码
R1(config)#enable secret 456   密文密码
1:password 123:配置console口密码,前提得进入console口,其后输入login提交命令
no password 123或no password  即可删除密码(console口模式下可加可不加)
2:enable password 123:  全局模式下给特权模式配置明文密码
enable secret 1234:  全局模式下给特权模式配置密文密码(密文密码将具有优先级,明文密码失效)
no enable secret/password:  清除密码(全局配置模式下不可加)
3:service password-encryption:加密明文密码
--------------------------------------------------------------------------------------------
修改寄存器值
Ctrl+break:重启路由器过程中中断IOS的加载
confreg 0x2142:默认0x2102,修改可使第六位为1绕过startup-config配置,需在ROM Monitor模式下输入,reset重启


config-register 2102:配置模式下修改寄存器的值为初始状态
------------------------------------------------------------------------------------------------------------
交换机的密码恢复命令
1.dir: 交换机中查看保存在Flash中的配置文件
2.Flash_init: 初始化Flash
3.rename flash:config.text flash:config.old   修改文件后缀名
4.boot:重启交换机,在故障恢复简单IOS的模式下有效
5.Sw1#rename flash:config.old flash:config.text  把配置文件的名称修改回来
copy flash:config.text system:running-config   加载配置文件,查看先前密码或直接略过此步用新密码覆盖
---------------------------------------------------------------------------------------------------
远程管理的配置
interface vlan 1  进入虚拟终端模式
R1(config)#int vlan 1  配置管理IP地址
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no sh  开启接口
line vty 0 4  只允许进入0-4这五个虚拟终端接口
R1(config)#lin vty 0  4   设置vty密码
R1(config-line)#password  123  密码
R1(config-line)#login   输入login表示应用上面的密码
在PC上登录telnet 192.168.1.1  表示使用主机远程连接对应的交换机
ip default-gateway 192.168.1.254  在路由器中设置网关
---------------------------------------------------------------------------------------------------
IOS备份,恢复和升级
{copy tftp flash} {ip} {Cisco设备文件名}:将IOS文件传输到路由器的Flash卡中
copy flash tftp:备份IOS
ip ftp username benet:最后你的名字
ip ftp password Cisco:最后你的密码
copy xmodem:flash 使用Xmodem协议传输iOS文件,故障恢复简单模式下
----------------------------------------------------------------------------------------------------
VLAN的配置
Sw1#vlan database  真机上使用此命令进入vlan模式
Sw1(vlan)#vlan 2 name 123  在vlan模式下设置vlanID和vlan名字
Sw1(vlan)#no vlan 2   删除对应vlan
Sw1(vlan)#exit  使用exit保存设置
Sw1(config)#vlan 2  全局模式下进入vlan模式

Sw1(config-vlan)#name 123  修改vlan名字
Sw1(config-vlan)#exit  使用exit保存设置
Sw1(config)#no vlan 2  全局模式下删除vlan
Sw1(vlan)#exit  使用exit保存设置
Sw1(config)#vlan 2  全局模式下进入vlan模式(有则进入,没有则创建)
Sw1(vlan)#exit/end  退出一步或回到特权
Sw1(config)#int range f0/1 - 24  选择要添加的接口
Sw1(config-if-range)#switchport mode access   定义二层端口的模式
Sw1(config-if-range)#switchport access vlan 2 把端口分配到某一个vlan中
Sw1(config)#interface f0/1                 进入一个接口
Sw1(config-if)#switchport mode access      定义二层端口的模式
Sw1(config-if)#switchport access vlan 2   把端口分配到某一个vlan中
Sw1(config-if)#exit   退出
Sw1(config)#default interface f0/1         还原接口到默认配置状态
Sw1#sh vlan breif  查看所有vlan信息
Sw1#sh vlan id 2  查看某一个vlan信息
------------------------------------------------------------------------------------------------------
Trunk的配置
Sw1(config)#int f0/24   进入要配置trunk模式的接口
Sw1(config-if)#switchport trunk encapsulation dot1q    选择封装的类型,真机必须使用
Sw1(config-if)#switchport mode trunk   配置trunk的命令(dynamic动态的,desirable期望的,auto自动的)可以选择配置的情况
Sw1#sh int f0/24 s  查看配置成trunk的接口的信息
Sw1(config-if)#switchport trunk allowed vlan remove  2   删除trunk中不需要的vlan
Sw1(config-if)#switchport trunk allowed vlan add  2    在trunk中添加需要的vlan
-------------------------------------------------------------------------------------------------------------
以太网通道设置
Sw1(config)#int r f0/1 - 3   选择要捆绑的接口
Sw1(config-if-range)#channel-group 1 mode on    捆绑命令

Sw1#show etherchannel summary    查看以太网通道的配置
------------------------------------------------------------------------------------------------------
单臂路由的配置
Sw1(config)#int f0/1  选择接口
Sw1(config-if)#switchport access vlan 2  添加到某一个vlan中
Sw1(config)#int f0/24   选择接口设置成trunk
Sw1(config-if)#switchport mode t   设置trunk的命令
为路由器设置trunk
R1(config)#int f0/0.1  进入f0/0的子接口
R1(config-subif)#encapsulation dot1Q 2    封装trunk到某一个vlan  
R1(config-subif)#ip add 192.168.1.1 255.255.255.0   为子接口设置ip地址
R1(config-subif)#exit 退出一步
R1(config)#Int f0/0
R1(config)#int f0/0
R1(config-if)#no  sh    开启物理总接口
使用路由器配置DHCP
R1(config)#ip dhcp pool 2  定义IP地址池 pool 加的是vlan编号
Router#show ip interface brief 查看子接口
R1(dhcp-config)#network 192.168.1.0 255.255.255.0   动态分配给客户端主机的IP地址范围
R1(dhcp-config)#default-router 192.168.1.1    为客户端主机指定网关地址
R1(dhcp-config)#dns-server 202.106.0.20    为客户端主机设置DNS地址,后面可以加多个备用的DNS地址
R1(dhcp-config)#lease 2    设置地址的租约期限
R1(config)#ip dhcp excluded-address 192.168.1.10  192.168.1.100预留静态分配的IP地址
----------------------------------------------------------------------------------
VTP的配置命令
vtp的配置
SW1(config)#vtp domain benet 创建vtp域
SW1(config)#vtp mode client 配置交换机的vtp模式
SW1(config)#vtp password pwd@123 配置vtp口令
SW1(config)#vtp pruning 配置vtp修剪
SW1(config)#vtp version 2 配置vtp的运行版本
SW1(config)#show vtp password 查看配置的vtp口令
SW1(config)#show vtp status 查看其他vtp的配置信息
SW1(config)#vtp password 123 配置VTP口令
 

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明