我的网站

Cisco PT模拟实验(9) 三层交换机的VLAN间路由

发布时间:2017-08-05 09:53

 实验目的: 

           掌握交换机 Tag VLAN 的配置
        掌握三层交换机 VLAN 路由 的配置方法
        通过三层交换机实现 VLAN 间相互通信
实验背景:
           公司财务部和销售部分别处于不同的办公室,为了安全和便于管理对两个部门的主机进行了VLAN 的划分,两个部门分处于不同的VLAN,现由于业务的需求,销售部和技术部的主机能相互访问,现要求对一台三层交换机进行适当配置。
技术原理:
按照OSI参考模型,交换机可分为二层交换机、三层交换机等。对于二层交换机,同一VLAN的主机位于同一个广播域,可彼此通信,而不同VLAN则。若要实现不同VLAN间的主机彼此通信,则必须使用第三层设备来提高路由选择功能。
三层交换机:既可以工作在OSI第三层替代或部分完成传统路由器的功能,同时又具有几乎第二层交换的速度,实质上是一种在性能上侧重于交换的特殊路由器。
VLAN间互访的原理:利用三层交换机的路由功能,通过识别数据包的IP地址,査找路由表进行路由转发,三层交换机利用直连路由可以实现不同VLAN之间的相互访问。
与二层交换机的区别:
二层交换机最为常见,工作于OSI模型第二层(数据链路层),即基于MAC地址进行通信,多应用于网络接入层和汇聚层;三层交换机工作于OSI模型第三层(网络层),即基于IP协议进行交换,普遍应用于网络的核心层。
SVI接口:即交换虚拟接口。是指三层交换机为各个VLAN配置IP地址的虚拟接口,作为VLAN的网关,用于不同VLAN之间互相访问,实现路由功能。
注意:二层交换机配置VLAN的IP地址只能作为设备管理地址,有且只有一个。
实验设备:Switch_3560 1台;Switch_2960 1台;PC 3台;直通线,交叉线。
实验拓扑:
 
实验步骤:
        新建Cisco PT 拓扑图
        在二层交换机上分别将PC0和PC2、PC1所接端口划入VLAN 2、VLAN 3。
        将二层交换机与三层交换机互连的端口配置为Trunk模式。
        验证二层交换机相同VLAN下主机可相互通信,不同VLAN下主机不能相互通信。
        配置两个SVI 口,分别作为两个VLAN 对应IP 子网的网关接口,配置对应的IP 地址
         查看三层交换机的路由表
 
PC设置
192.168.1.2        //PC0
192.168.1.3        //PC2
//子网掩码和网关
255.255.255.0
192.168.1.1
 
PC设置
192.168.2.2        //PC1
//子网掩码和网关
255.255.255.0
192.168.2.1
 
S2960配置
Switch>en
Switch#config t
Switch(config)#vlan 2
Switch(config-vlan)#vlan 3
Switch(config-vlan)#exit
Switch(config)#inter f0/2
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#inter f0/3
Switch(config-if)#sw ac vlan 3
Switch(config-if)#exit
Switch(config)#inter f0/1
Switch(config-if)#sw mode trunk
Switch(config-if)#end
Switch#show vlan
 
S3560配置
Switch>en
Switch#config t
Switch(config)#vlan 2
Switch(config-vlan)#vlan 3
Switch(config-vlan)#exit
Switch(config)#inter f0/1
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#sw mode trunk
Switch(config-if)#exit
Switch(config)#inter f0/1
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface vlan 2
Switch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 3
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#end
Switch#show ip route
Switch#show
 
8
# 链路测试
PC0(命令提示符CMD下)
ping 192.168.1.1                  //链路通
ping 192.168.2.1                  //链路通
ping 192.168.2.2                  //链路通
PC1(命令提示符CMD下)
ping 192.168.1.2                  //链路通
//备份链路标记由黄色变为绿色,表明备份链路已启用
  • 上一篇:CISCO路由器license激活图解教程
  • 下一篇:没有了
  • 关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明