192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

Rays wifizoo

发布时间:2011-02-20 19:32

  弄了个WBR2-G54S玩,连上由一看是buflo的原版固件,打算把它刷成DDWRT。

  于是直接用TFTP升级DDWRT固件,顺利刷新。

  结果噩梦来临,由器不断重启,ping192.168.1.1-t,在由器启动的bootwait几秒钟可以ping通,TTL值为100,重新TFTPDDWRT固件,可以成功上传并重启,但是仍旧反复重启。

  按照以前论坛里的解决方案,这种情况只能JTAG清除NVRAM。如果是WHR-HP-G54可以按下init键不放加电,30秒钟后松开,即可成功清除NVRAM,然后TFTP上传固件到192.168.11.1即可。但是我试过无效,貌似只对G54的有效,应该是CFE不同所致。

  由于手边没有JTAG线以及螺丝刀,又不想明天带到公司搞,思索一下,由器的CPU貌似不能工作在264MHZ,现在只要清除掉NVRAM,使由器启动时不加载参数clkfreq=264MHZ即可解决问题。既然可以TFTP,那么何不用固件TFTP一下试试,两者的初始化IP地址不一样,应该可以利用这个bug使之前的NVRAM无效。

  问题解决。

  去虬江玩,淘了个cablemodem的猫回来,BCM方案,RAM8M,USB是作为网卡用的,不可以接USB存储设备。

  上电试机,发现似乎是好的,苦于不知道猫预置的IP,无法进入猫的WEB界面一睹芳容。幸好有TTL插座,直接把TTL数据线连上去,用putty观察猫的启动信息。

  继续观察,发现接下来开始CRC校验,然后进入Vxworks系统。

  WEB界面里有个configuration选项,是需要输入用户名密码的,试了几个常见不管用,放狗搜了一下,在国外一个论坛里找到答案,用户名infinite密码SetValue。好BT的密码哟,估计猜死都猜不出来!

  于是telnet192.168.100.1,提示需要输入用户名密码,WEB界面的用户名密码不适用,无法telnet登陆。

  串口下还是有一些指令可用的:

  192.168.11.1打不开闲置的一个SATA硬盘居然有坏道,无法在linux下格式化为EXT3,无奈在淘宝上拍了个160G的IDE硬盘,到手开始安装。

  去下载了HD-HLAN的升级程序包,解压缩备用。

  把IDE硬盘挂在台式机上用diskgen删除了分区,然后挂在linkstation,把后面的开关拨到"x”的,手工指定电脑的IP为192.168.11.X网段,然后关闭电脑的防火墙,拿网线连接电脑,运行解压后文件夹里的,这时会发现软件找到了linkstation,并且为EM模式,点击"RenewFirmware"开始升级。

  其实往flash里写firmware的过程很快,接下来就是把extrasystem写入IDE硬盘,升级过程中两个红灯会不断闪烁,此时应该是格式化并写入硬盘中,这段时间大约在5分钟左右。

  此时千万不要断电或者断开网线,否则后果很严重。如果刷的是buflo的stock固件的话倒是还有补救的机会,因为boot是stock的,此时还可以识别linkstation并进入EM模式,只要重新刷就可以了。如果刷的是freelink的话就麻烦了,因为刷freelink的时候会把原版的boot刷新为freelink的boot,万一进不了系统的话buflo的是不会识别这个boot的,也就无法进入EM模式,这时又有两个选择:一是用风枪吹下flash上编程器重写,前提是你有固件的编程器备份。二是用JTAG重写flash。

  拍了几张刷写过程中的照片:

  但是刷写过程结束之后却跳出提示:Attempttorenewfirmwarehasiled。幸好刷机之前已经做足了功课,把可能出现的情况几乎都考虑到了。这种情况的话不要退出升级程序,直接重刷即可。

  重刷之后问题解决,显示升级成功。由于刷的是freelink,重启后却无法打开WEB界面,只能telnet进去,发现是debian,cat/proc/cpuinfo看了一下,BogoMIPS值才不到180,跑mldonkey下载同时访问samba,速度很慢,才2M/S,想来反正有由器和终端机都可以做下载机,这个东东还是当个专门的网络硬盘好了。一怒之下刷回原版固件。这下访问速度快多了,5M/S左右,基本满足要求。

  刷了buflo的1.48版本固件后,有Pcast功能。可以联机电视机等设备,播放流内容,这倒是个不错的选择。

  上周突然毫无征兆的打不开博客页面,ping一下才发现是服务器挂了。当时没想太多,以为是例行的停机,可是到了第二天依旧没有恢复,急吼吼地打开淘宝找给我空间的人,原来是服务器放了太多没有备案的网站,被当地查了,现在还在停机中,何时能恢复运行还未可知,至于恢复运行后能否继续给没有备案的网站提供服务,答复是基本不可能。

  自从买了一个服务商的虚拟空间后真是命途多舛,三个月前服务器被黑,数据库全部丢失,幸好隔三差五的做个备份,总算又恢复运行,还没稳定运行三个月呐,服务器又被当地机关查封,虽说买的空间没花几个钱,可是这样时不时出点问题也太人了。想来想去,还是把终端机搞起来,自己搭建服务器跑博客吧。

  正好前几天拉了4M的通,用的是cablemodem,网速还算可以,不打折扣,测试HTTP下载450KB/S,由器挂U盘跑mldonkey下载,端口映射之后就是高ID了,轻松跑上200KB/S,可惜是USB1.1,否则跑个满速一点问题都没有。

  添加了IIS和ASP以及NET组件,把博客挂上去跑起来,内网测试OK,去由器上把端口映射出去,用OnlinePortScanner一看,80端口居然没有打开!,难道是由器出问题了?

  但是测试其他已映射端口,都没有问题。再把内网的80端口随便映射到外网的8000端口去,完全可以访问,看来是通封了外网访问内网的80端口,只能内网单向访问外网了。

  郁闷加无奈,域名是3322的,做备案自然不可能通过,单单为了个博客去花钱买域名似乎也没有必要,只好去淘宝买国外的空间了。

  终于找到一个美国的空间,支持ASP,可以域名绑定,支持在线解压缩和打包,速度还不错。上传了博客试运行一下,速度还不错。登陆管理界面一看跑的是HZhost,丢了个免杀的马上去,发现系统时间居然是东八区,跑的是2K3中文版,搞不懂为什么不是美国当地的时间。不过SERV-U提权这样明显的漏洞还是没有地,终于可以放心了,呵呵。

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明