192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

4台路由器和2台PC上完成的静态NAT实验

发布时间:2013-01-13 15:09

4台路由器和2台PC的组网的拓扑图如下:

wps_clip_image-13692

静态nat实验:

首先配置各个接口的ip,所有路由器使用rip v2协议,R5禁用路由功能,插上交换模块,当作交换机使用在本实验中。

R5上命令如下:

R5(config)#no ip routing

R5(config)#int vlan 1

R5(config-if)#ip add 192.168.10.10 255.255.255.0

R5(config-if)#no shut

R5(config-if)#ip default-gateway 192.168.10.1

R3上用acl禁用私有ip网段,命令如下:

Router(config)#access-list 1 deny 192.168.0.0 0.0.255.255

Router(config)#access-list 1 dney 172.16.0.0 0.15.255.255

Router(config)#access-list 1 deny 10.0.0.0 0.255.255.255

Router(config)#access-list 1 per any      # 配置ACL

Router(config)#int f1/0

Router(config-if)#ip access-group 1 in    #在端口入方向上上启用此ACL

此时PC上ping 4.4.4.4 是不通的,如下图:

wps_clip_image-31738

在r1上设置默认路由:

Router(config)#ip route 0.0.0.0 0.0.0.0 f1/1

Router(config)#int f1/0

Router(config-if)#ip nat inside #配置nat内部接口

Router(config-if)#int f1/1

Router(config-if)#ip nat outside  #配置nat外部接口

Router(config-if)#exit

Router(config)#ip nat inside source static 192.168.10.2 23.1.1.5 #每条内部地址对应一个 公网ip

Router(config)#ip nat inside source static 192.168.10.3 23.1.1.6

客户端测试,可以ping通4.4.4.4,如下图:

wps_clip_image-7441

在r4上debug ip icmp观察,如下图:

wps_clip_image-10566

Icmp回应包的目的地址是23.1.1.5 , 说明配置成功。

动态NAT实验:

动态NAT思路:

1) 用ACL过滤内网网段

2) 建立公网ip地址池

3) Ip nat inside source “ACL 列表” pool “pool 名称”

同样是上面的拓扑图,接口ip配置都相同,不同的是把配置静态NAT的那两条语句删除,添加如下语句:

Router(config)#access-list 1 permit 192.168.10.0 0.0.0.255

Router(config)#ip nat pool zh 23.1.1.10 23.1.1.20 netmask 255.255.255.0

Router(config)#ip nat inside source list 1 pool zh

客户端测试,同时R4 debug ip icmp ,如下图:

看R1的转换表,如下图:

wps_clip_image-30525

说明配置成功。

PNAT(端口复用技术实验)

公网ip的使用是需要购买的,企业一般不会购买很多的公网ip,但是企业内部的客户机数量有很多,一方面为了节约成本,一方面也为了节约ipv4,可以考虑把企业内部私有ip转换成一个公网ip,路由器中通过公网ip加端口标识私有ip。

PNAT思路:

(1)用ACL把内网ip过滤出来

         (2)指定将哪个ANL转成哪个接口的ip并指定端口复用

删除之前配置的两条记录,添加如下语句:

Router(config)#ip nat inside source list 1 interface f1/1 overload

客户端都ping 4.4.4.4 ,可通,查看nat表,如下:

wps_clip_image-3910

至此,PNAT实验完成。

DNAT(目标地址转换)实验

目标:外网4.4.4.4 想要访问公司内网网站,ftp服务器,文件服务器等服务。

实现:把内网主机对应服务的端口映射到网关的公网上某个端口

还是上面的拓扑,配置都不变。此时,外网是无法远程管理交换机的,为了让外网可以远程telnet登录内网交换机,做如下操作:

R1上添加如下命令:

Router(config)#ip nat inside source static tcp 192.168.10.10 23 23.1.1.1 23 #把内部交换机管理地址的23端口映射到默认网关的23端口

在R4上测试,如下:

wps_clip_image-15858

查看R1上,如下:

wps_clip_image-18694

wps_clip_image-12337

证明端口映射成功。

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明