192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

IP SLA实现自动切换冗余链路,防止路由黑洞(多ISP接入常用)

发布时间:2017-04-12 09:48

在R2、R3、S2、S3配了ospf路由通了,路由表也学习到了,然后去S1、S2、S3配生成树,结果所有接口都堵死了,包括路由器的串口。生成树选举出根桥后接口又重新通了,所以是不是生成树影响到了路由器?还有这个拓补里怎么形成的环路?

大家好,I am Mr.w, My OICQ  number is 246088063    By Mr.w
IP <wbr>SLA实现自动切换冗余链路,防止路由黑洞(多ISP接入常用)

如图:让R3的所有流量走R1,当R1不正常的时候走R2,这就是默认路由的备份
 
ip route 0.0.0.0 0.0.0.0 10.1.1.2
ip route 0.0.0.0 0.0.0.0 20.1.1.2 10  //设定管理距离比 R1大,所有进入不了路由表,上面一条路由出现问题消失的时候下面的路由就会进入路由表。
 
但是这里会出现一个问题,如果中间有一个透明设备,比如这里的交换机
当对端消失的时候,默认路由还是不会消失。
 
 
在交换机的f0/2 与 f0/3 抓包:
正常的时候:
IP <wbr>SLA实现自动切换冗余链路,防止路由黑洞(多ISP接入常用)

如下图:R2是没有流量流入的
IP <wbr>SLA实现自动切换冗余链路,防止路由黑洞(多ISP接入常用)


总结:正常的时候全部都走了R1这条链路

断开R1:   
 
R3#show ip route                     
Gateway of last resort is 10.1.1.2 to network 0.0.0.0
 
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 10.1.1.2
 
注意:这里已经断开了R1的f0/0,但是R3上还是显示他的存活,如果这个发生在现实的网络中将导致通信失败。
 
为了解决这类问题,我们引用了IP SLA这个工具。
 
ip sla 1  //定义序列号为1的SLA
 icmp-echo 10.1.1.2 source-interface FastEthernet0/0  //利用icmp-echo请求来判断是否存活
ip sla schedule 1 life forever start-time now      //全局模式下配置,设定一个计划并即可生效
ip sla 2
 icmp-echo 20.1.1.2 source-interface FastEthernet0/1
ip sla schedule 2 life forever start-time now
 
track 10 rtr 1 reachability   //定义到track组
 
track 20 rtr 2 reachability
 
ip route 0.0.0.0 0.0.0.0 10.1.1.2 track 10   //应用到默认路由上
ip route 0.0.0.0 0.0.0.0 20.1.1.2 track 20
 
R3#show ip route
Gateway of last resort is 20.1.1.2 to network 0.0.0.0
 
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1


     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 20.1.1.2
               [1/0] via 10.1.1.2
 
这里默认都是走R2了,为了达到上面的要求:如下配置
ip route 0.0.0.0 0.0.0.0 20.1.1.2 track 20 10  //在后面增加一个AD值即可
IP <wbr>SLA实现自动切换冗余链路,防止路由黑洞(多ISP接入常用)

由上图可知默认都是走R1线路
 
注意:对于对端down之后,因为SLA发送ICMP有一个间隔时间,所以在这段时间会出现通信失败  //由于每个IOS不同,配置的SLA也是不一样的。
R3#
Nov 21 11:04:48.219: %TRACKING-5-STATE: 10 rtr 1 reachability Up->Down
//以上就是通过SLA 判断了 对端down了
R3#show ip route
Gateway of last resort is 20.1.1.2 to network 0.0.0.0
 
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [10/0] via 20.1.1.2
 
 
以上可知,显然 10.1.1.0/24 还在存活,但是通过SLA已经得知对端down了。
 
这个案例已经结束。
 
下面 我们结合route-map 策略路由我们讲解下一个常用的现实环境:
IP <wbr>SLA实现自动切换冗余链路,防止路由黑洞(多ISP接入常用)

让192.168.1.0网段的流量从ISP1走,链路断开走ISP2
让192.168.2.0网段的浏览从ISP2走,  链路断开走ISP1
 
为了实现自动切换,只能使用route-map,定义2条SET,利用只会执行一条SET这个条件,实现断开ISP某一条链路就会执行下面的SET.
 
 
track 10 rtr 1 reachability
!
track 20 rtr 2 reachability
 
 
ip sla 1
 icmp-echo 10.1.1.2 source-interface FastEthernet0/0
ip sla 2  http://www.luyouqiwang.com/
 icmp-echo 20.1.1.2 source-interface FastEthernet0/1
 
access-list 1 permit 192.168.1.0 0.0.0.255  //定义访问控制列表
access-list 2 permit 192.168.2.0 0.0.0.255
!
route-map isp2 permit 10
 match ip address 2
 set ip next-hop verify-availability 10.1.1.2 1 track 10 
 set ip next-hop verify-availability 20.1.1.2 2 track 20
//注意:这里定义2条,当ISP1存活,只会执行一条SET,当断开的时候才会执行下面的SET


!
route-map isp1 permit 10
 match ip address 1
 set ip next-hop verify-availability 10.1.1.2 1 track 10
 set ip next-hop verify-availability 20.1.1.2 2 track 20  //同上解释
 
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.0
 ip policy route-map isp1   //应用到接口下
interface FastEthernet2/0
 ip address 192.168.2.1 255.255.255.0
 ip policy route-map isp2  //应用到接口下
IP <wbr>SLA实现自动切换冗余链路,防止路由黑洞(多ISP接入常用)

上图为正常的时候 PC1 Ping 8.8.8.8 走ISP1
R3#debug ip policy
Nov 21 12:39:30.955: IP: s=192.168.1.2 (FastEthernet1/0), d=8.8.8.8, len 100, policy match
Nov 21 12:39:30.955: IP: route map isp1, item 10, permit
Nov 21 12:39:30.955: IP: s=192.168.1.2 (FastEthernet1/0), d=8.8.8.8 (FastEthernet0/0), len 100, policy routed
Nov 21 12:39:30.959: IP: FastEthernet1/0 to FastEthernet0/0 10.1.1.2
//此时走的是10.1.1.2  (ISP1)
 
R3#
Nov 21 12:41:19.787: %TRACKING-5-STATE: 10 rtr 1 reachability Up->Down
//当ISP1 down之后
IP <wbr>SLA实现自动切换冗余链路,防止路由黑洞(多ISP接入常用)

R3#
Nov 21 12:41:47.871: IP: s=192.168.1.2 (FastEthernet1/0), d=8.8.8.8, len 100, policy match
Nov 21 12:41:47.871: IP: route map isp1, item 10, permit
Nov 21 12:41:47.871: IP: s=192.168.1.2 (FastEthernet1/0), d=8.8.8.8 (FastEthernet0/1), len 100, policy routed
Nov 21 12:41:47.875: IP: FastEthernet1/0 to FastEthernet0/1 20.1.1.2
// 此时走的是20.1.1.2(ISP2)
 
 总结:IP SLA 结束了,谢谢大家支持!

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明