192.168.1.1-路由器设置 | 192.168.0.1-无线路由器设置

路由协议之RIP的工作原理和应用

发布时间:2015-04-13 10:16

         路由信息协议(Routinginformation Protocol,缩写:RIP)是内部网关IGP中最先得到广泛使用的协议。RIP是一种距离矢量的路由协议,是因特网的标准协议,其最大的特点就是实现简单,开销较小。

         RIP只实验跳数来决定到达某个互联网络的最佳路径。如果RIP发现对同一个远程网络存在不止一条链路,并且他们都具有相同的跳计数,则路由器将自动执行循环负载。RIP最多可以对6条相同开销的链路实现负载均衡。

  • RIP工作原理

  •  RIP路由协议向邻居发送整个路由表信息

  • RIP路由协议用跳数作为度量值,更加跳数多少来选择最佳路由

  • 最大跳数为15跳,16跳为不可达(这样会严重限制网络的规模)

  • 会聚

            RIP定时器路由更新定时器:每隔30秒,路由器向相邻的路由器发送完整的路由表

            路由无效定时器:如果一条路由在180秒内没有收到更新,这条路由的条数标记为16跳(表

                示不可达)

            路由刷新定时器:如果一条路由被标记为无效后,又过了60秒(总共240秒)还没有收到更

                新,则将这条路由从路由表中删除。

RIP路由分类

1.      RIPv1:是有类路由协议,也就是路由更新时 ,不携带子网掩码,而是使用IP的标准子网掩码,简单来说就是如果路由器上设置啦可变长子网掩码,如f0/0接口IP为一个C类地址:192.168.1.4/26,但是路由更新时宣告的网段依然是C类地址的标准掩码192.168.1.0/24

2.      RIPv2:是无类路由协议,发送路由跟新是,携带子网掩码。

RIP协议实验

思科设备配置如下

 

IP设置如下:

   R1Fa0/0  192.168.1.1/24Fa0/1  192.168.2.1/24

   R2Fa0/0  192.168.2.2/24Fa0/1  192.168.3.1/24

   R3Fa0/0  192.168.3.2/24Fa0/1  192.168.4.1/24

   PC1192.168.1.2/24   Gateway192.168.1.1

   PC2192.168.4.2/24   Gateway192.168.4.1

R1配置

   R1>enable                                         进入特权模式

   R1#configure terminal                             进入全局模式

            R1(config)#router rip                     启用RIP路由协议

R1(config-router)#network 192.168.1.0          宣告这台路由器所直连的网段

R1(config-router)#network 192.168.2.0

R1(config-router)#version 2                    选择使用RIPv2

R1(config-router)#do write                     保存配置

R2配置
 

R2>enable

   R2#configure terminal

            R2(config)#router rip

R2(config-router)#network 192.168.2.0

R2(config-router)#network 192.168.3.0

R2(config-router)#version 2

R2(config-router)#do write

R3配置

R3>enable

   R3#configure terminal

            R3(config)#router rip

R3(config-router)#network 192.168.3.0

R3(config-router)#network 192.168.4.0

R3(config-router)#version 2

R3(config-router)#do write

上述设置完成后在PC1使用网络诊断工具(ping)测试网络连通性


      RIP查看命令

        R1#show ip route                             查看路由表(R代表RIP路由协议)
 

        R1#show ip protocols                                  查看路由器使用协议

            Routing Protocol is "rip"      

            #协议名称

            Sending updates every 30 seconds,next due in 13 seconds

            #每30秒更新一次,下次更新还有13秒

            Invalid after 180 seconds,hold down 180,flushed after 240

            #保持时间180秒   抑制时间  无效时间240秒

            Outgoing update filter list for all interfaces is not set

            Incoming update filter list for all interfaces is not set

            Redistributing: rip

            Default version control: send version 2, receive 2

            #发送协议版本为2,只接受RIP2协议(如果使用的RIPv1的话,可以接受任何版本的协议)

            Interface            Send  Recv  Triggered RIP Key-chain

            FastEthernet0/0       2     2    

            FastEthernet0/1       2     2    

            #允许RIP协议的端口

            Automatic network summarization is in effect

            Maximum path: 4

            Routing for Networks:

            192.168.2.0

            192.168.3.0

            #路由网络

            Passive Interface(s):

            Routing Information Sources:

            Gateway         Distance      Last Update

            192.168.2.1          120      00:00:27

            192.168.3.2          120      00:00:06

            #获取路由信息的源

            Distance: (default is 120)

            #默认AD

华为设备配置如下

 

IP配置如下

       AR1               GE0/0/0  192.168.1.1/24     GE0/0/1  192.168.2.1/24

             AR2               GE0/0/0  192.168.2.2/24     GE0/0/1  192.168.3.1/24

             AR3               GE0/0/0  192.168.3.2/24     GE0/0/1  192.168.4.1/24

             CLENT1            192.168.1.2/24                Gateway192.168.1.1

             CLENT2            192.168.4.2/24                Gateway192.168.4.1

AR1配置

<Huawei>system-view                                进入系统视图

[Huawei] sysname AR1                               修改设备名为AR1

[AR1]interface g0/0/0                              进入g0/0/0接口配置IP地址

[AR1-GigabitEthernet0/0/0]ipadd 192.168.1.1 24 设置ip地址,这里子网掩码可以简写

[AR1-GigabitEthernet0/0/0]undo shutdown            开启接口

     以下IP地址配置过程省略

[AR1]rip 1111                   启用rip1111代表进程号,范围(1-65535

[AR1-rip-1111]network 192.168.1.0       宣告直连网段

[AR1-rip-1111]network 192.168.2.0

[AR1-rip-1111]version 2                 启用RIPv2

[AR1-rip-1111]return                    退回用户视图

<AR1>save                               保存当前配置,会询问是否继续,输入y回车

      AR2配置

[AR2]rip 1111     

[AR2-rip-1111]network 192.168.2.0

[AR2-rip-1111]network 192.168.3.0

[AR2-rip-1111]version 2    

[AR2-rip-1111]return

<AR2>save

      AR3配置

[AR3]rip 1111     

[AR3-rip-1111]network 192.168.3.0

[AR3-rip-1111]network 192.168.4.0

[AR3-rip-1111]version 2    

[AR3-rip-1111]return

<AR3>save

上述配置完成后使用CLENT1测试网络连通性

路由查看命令

   <AR1>display ip routing-table                      查看路由表

   <AR1>display ip routing-table protocolrip          查看rip路由信息

   <AR1>display rip 1111 database                     查看rip发布数据库的所有几乎路由

   <AR1>display rip                                   查看rip详细信息

提示

1RIPRIP-1RIP-2两个版本,可以指定接口所处理的RIP报文版本。

2RIP-1的报文传送方式为广播方式。

3RIP-2有两种报文传送方式:广播方式和组播方式,缺省将采用组播方式发送报文。RIP-2中组播地址为224.0.0.9

4、由于RIP本身的诸多缺陷,不推荐使用RIP作为IGP路由协议,推荐使用OSPF

关于我们 - RSS地图 - 最近更新 - 友情链接 - 网站地图 - 版权声明